Maintenance has completed successfully and outage is resolved.
Update
May 16, 2022 at 2:25 AM
Update
May 16, 2022 at 2:25 AM
We believe we have located the root cause of the issue and are working in collaboration with our domain registrar to resolve the issue. This page will be updated as we learn more.
Update
May 15, 2022 at 9:36 PM
Update
May 15, 2022 at 9:36 PM
We are aware of a major website outage caused by this maintenance. It should be resolved within 24 hours. We'll update you as we know more.
In progress
May 10, 2022 at 5:25 PM
In progress
May 10, 2022 at 5:25 PM
During this period, the epicstudios.space domain will be transferring between registrars. The website may be temporarily inaccessible.